- cross-posted to:
- programmer_humor@programming.dev
- cross-posted to:
- programmer_humor@programming.dev
I hate that schools basically teach students to over use classes for everything especially by using Java as a teaching language and then they get into the real world or grad school and we have to unteach them those terrible habits.
I’m so glad a lot of the newer languages (Rust, Go, Zig, C3, V) don’t have classes in them at all.
Tbh if the average grad school student overused object oriented stuff they would produce vastly better code than the status quo.
I strongly disagree.
I’m currently taking the very last CS class my major requires. I can’t wait to leave OOP behind and focus on hardware completely.
where do you plan to go to start that off after school?
Strings are Objects, Doubles are Objects (that are than unboxed into primutives doubles)…
You did the right thing. OOP was invented by people who were worried about their job security, to obstruct others from understanding their code.
OOP is pretty readable though. What would be the alternative, functional programming with no ORM?
Well, bad code is bad code regardless of the paradigm. I’ve just had bad experiences rewriting some horrible OOP codebases and opted out to use as much functional style as C# allowed me to.
The main problem, as I see it, is that OOP encourages unnecessary abstractions and inheritance. These should be used as little as possible, because they typically increase complexity and make code harder to read and untangle. As an example, I’ve seen people define interfaces that don’t essentially define anything.
Another problem is that OOP encourages mutable member variables. It’s very annoying to try to understand code where class C inherits from class B that inherits from class C. Good luck debugging when the methods of C modify a variable declared in A in subtle ways.
As an idea OOP is very appealing. When I was younger, I would be thrilled to start designing a class hierarchy and interfaces when encountering a new programming challenge. Now I just try to think how to make things as simple and modular as possible.
Edit: of course bad functional code is also bad code. It’s also very annoying to try to understand code where functions pass badly named functions around as parameters and use 10 function compositions in a sequence.
Right, most things are a fine thing in moderation.
Obfuscation Oriented Programming as I call it
Good, OOP can suck my balls
Balls.suck() is the correct syntax.
Actually, it would be
OOP.suck(ddplf.getBalls())
Don’t you need to declare new Balls() first? Or do you suck() Balls static?
BallsFactory ballsFactory = new BallsFactory(); ballsFactory.setSuckable(true); Balls balls = ballsFactory.create();
All of this is okay, but it’s not production ready. This is what real production code looks like:
SuckableFactory suckableFactory = new SuckableFactory(); Suckable balls = suckableFactory .setShape(SuckableShapes.round) .setCount(2) .create(); SuctionProvider mouth = SuctionProvider.getInstance(); SuckerFactory suckerFactory = new SuckerFactory(); Sucker sucker = SuckerFactory.create(): sucker.setSuctionProvider(mouth); sucker.setSuckable(balls); sucker.setIntensity(SuckerSuctionIntensities.medium); sucker.suckSuckable();
Python port:
from ballsucker import suck suck()
Or I didn’t using the correct naming convention!